How to Configure EIGRP on Cisco Router step by step

EXPERIMENT No-13

OBJECT: Simulation of EIGRP Configuration in Cisco Router
REQUIRED SOFTWARE: Cisco Packet Tracer 8.1.1

Network Diagram

Configure this network:

How to Configure EIGRP on Cisco Router step by step

Router>ena
Router#config t
Router(config)#hostname RouterA
RouterA(config)#int fa 0/0
RouterA(config-if)#ip address 192.168.1.1 255.255.255.0
RouterA(config-if)#no shut
RouterA(config-if)#int se 2/0
RouterA(config-if)#ip address 10.0.0.1 255.0.0.0
RouterA(config-if)#no shut
RouterA(config-if)#exit
RouterA(config)#exit

RouterA#show ip route
RouterA#config t
RouterA(config)#router eigrp ?
<1-65535> Autonomous system number
RouterA(config)#router eigrp 10
RouterA(config-router)#network 10.0.0.0 (Advertise with ?) default subnet mask
RouterA(config-router)#network 192.168.1.0 0.0.0.255 (With ? Inverse Subnet mask 255.255.255.0 0.0.0.0255)
RouterA(config-router)#exit
RouterA(config)#exit
RouterA#

Router>ena
Router#config t
Router(config)#hostname RouterB
RouterB(config)#int fa 0/0
RouterB(config-if)#ip address 192.168.2.1 255.255.255.0
RouterB(config-if)#no shut
RouterB(config-if)#int se 3/0
RouterB(config-if)#ip address 10.0.0.2 255.0.0.0
RouterB(config-if)#clock rate 64000
RouterB(config-if)#no shut
RouterB(config-if)#int se 2/0
RouterB(config-if)#ip address 20.0.0.1 255.0.0.0
RouterB(config-if)#no shut
RouterB(config-if)#exit

RouterB#show ip route
RouterB#confit t
RouterB(config)#router eigrp 10
RouterB(config-router)#network 10.0.0.0
RouterB(config-router)#network 20.0.0.0
RouterB(config-router)#network 192.168.2.0
RouterB(config-router)#exit
RouterB(config)#exit
RouterB#

Router>ena
Router#config t
Router(config)#hostname RouterC
RouterC(config)#int fa 0/0
RouterC(config-if)#ip address 192.168.3.1 255.255.255.0
RouterC(config-if)#no shut
RouterC(config-if)#int se 3/0
RouterC(config-if)#ip address 20.0.0.2 255.0.0.0
RouterC(config-if)#clock rate 64000
RouterC(config-if)#no shut
RouterC(config)#exit
RouterC#

RouterC#show ip route
RouterC#config t
RouterC(config)#router eigrp 10
RouterC(config-router)#network 192.168.3.0
RouterC(config-router)#network 20.0.0.0
RouterC(config-router)#exit
RouterC(config)#exit
RouterC#

Important Command
sh ip route
sh ip pr
sh ip eigrp neighbors
sh ip eigrp topology


Download Cisco Packet Tracer 6.22
Download Cisco Packet Tracer 8.1.1

MCQ-SET 1

Dear Students, This Purpose of Preparation of Computer Network Online Test is in 30 Questions English. There is a collection of questions asked in the CCNA Exam. On answering each question one point will be given. And it is mandatory to bring 50% marks to pass. To start the test you have to click on Start Button. All the questions will have to be answered. Go to Last and click on Finish Button, after which your Result will appear on the screen. After clicking Finish, there will be three option shows below 1.Restart Quiz 2.View Question 3.Show Leader-board. After filling your name and e-mail id by clicking on the show leader-board, click on send, after which your result will be shown.

MCQ-SET 2

1. What type of switching creates variable latency through the switch?




Answer is B)
Store and Forward.


2. Which layer of the 7 layer model provides services to the Application layer over the Session layer connection?




Answer is D)
Presentation


3. Which OSI Reference Layer controls application to application communication?




Answer is C)
Session

4. What is a characteristic of Store and Forward switches?




Answer is B)
Frames

5. What is the standard ISDN term for a non-native analog telephone?




Answer is B)
TE2

6. Which OSI Reference Layer is concerned with path determination?




Answer is D
Network

7. If you are running Token Ring with Novell IPX routing, which encapsulation should you use?




Answer is D)
SNAP

8. An ISDN BRI circuit can be described as which of the following?




Answer is A)
2-64Kbps B channels and 1-16Kbps D channel

9. Which of the following describes the creation of private networks across the Internet, enabling privacy and tunneling of non-TCP/IP protocols?




Answer is B)
VPN

10. Which of the following describes an industry-wide standard suite of protocols and algorithms that allows for secure data transmission over an IP-based network that functions at the layer 3 Network layer of the OSI model?




Answer is C)
IPSec

11. In which of the following technologies is the term HFC used?




Answer is B)
Cable Explain: In a modern network, hybrid fibre-coaxial (HFC) is a telecommunications industry term for a network that incorporates both optical fiber and coaxial cable to create a broadband network.

12. Which of the following is true when describing a global unicast address?




Answer is A)
These are your typical publicly routable addresses, just like a regular publicly routable address in IPv4.

13. Which of the following is true when describing a unicast address?




Answer is C)
Packets addressed to a unicast address are delivered to a single interface.

14. Which of the following is true when describing a link-local address?




Answer is D)
These are like private addresses in IPv4 in that they are not meant to be routed.

15. Which of the following is true when describing a unique local address?




Answer is A)
These addresses are meant for nonrouting purposes, but they are almost globally unique so it is unlikely they will have an address overlap.

16. Which of the following is true when describing a multicast address?




Answer is C)
Packets are delivered to all interfaces identified by the address. This is also called a one-tomany address.

17. Which command will allow you to see real-time translations on your router?




Answer is A)
debug ip nat

18. Which command will show you all the translations active on your router?




Answer is D)
show ip nat translations

19. Which command will clear all the translations active on your router?




Answer is B)
clear ip nat translations *

20. Which of the following is an example of a standard IP access list?




Answer is A)
access-list 1 deny 172.16.10.1 0.0.0.0

21. You need to create an access list that will prevent hosts in the network range of 192.168.160.0 to 192.168.191.0. Which of the following lists will you use?




Answer is D)
access-list 10 deny 192.168.160.0 0.0.31.255

22. You have created a named access list called Blocksales. Which of the following is a valid command for applying this to packets trying to enter interface s0 of your router?




Answer is A)
(config-if)#ip access-group Blocksales in

23. Which of the following access lists will allow only HTTP traffic into network 196.15.7.0?




Answer is D)
access-list 100 permit tcp any 196.15.7.0 0.0.0.255 eq www

24. A Cisco router is booting and has just completed the POST process. It is now ready to find and load an IOS image. What function does the router perform next?




Answer is B)
It checks the configuration register.

25. For IPX, what is the DEFAULT Cisco Encapsulation on an Ethernet interface?




Answer is A)
novell-ether

26. Which class of address allows for the fewest valid Internet hosts?




Answer is D)
class C

27. What is a characteristic of Store and Forward switches?




Answer is D)
They increase latency

28. Which OSI Reference Layer controls application to application communication?




Answer is B)
Session

29. What is a characteristic of Store and Forward switches?




Answer is A)
Frames

30. What is the standard ISDN term for a non-native analog telephone?




Answer is D)
TE2

How to Configure OSPF on Cisco Router step by step
About me