How to Configure Spanning Tree Protocol on Cisco Switch

EXPERIMENT No-10

OBJECT: Simulation of Spanning Tree Protocol.
REQUIRED SOFTWARE: Cisco Packet Tracer 8.1.1

Network Diagram

Setup this network:

How to configure Spanning Tree Protocol on Cisco Switch
Switch>ena
Switch#config t
Switch(config)#hostname S1
S1(config)#interface range fa0/1-24
S1(config-if-range)#shutdown
S1(config-if-range)#interface fa0/3
S1(config-if)#switchport mode access
S1(config-if)#no shutdown
S1(config-if)#interface range fa0/1, fa0/2
S1(config-if-range)#switchport mode trunk
S1(config-if-range)#no shutdown
S1(config-if-range)#interface vlan 1
S1(config-if)#ip address 172.17.10.1 255.255.255.0
S1(config-if)#no shutdown
S1(config-if)#exit
S1#sh spanning-tree 

VLAN0001
  Spanning tree enabled protocol ieee
  Root ID    Priority    32769
             Address     0001.438D.229D
             Cost        19
             Port        2(FastEthernet0/2)
             Hello Time  2 sec  Max Age 20 sec  Forward Delay 15 sec
  Bridge ID  Priority    32769  (priority 32768 sys-id-ext 1)
             Address     00D0.D3CA.B23C
             Hello Time  2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time  20
Interface        Role Sts Cost      Prio.Nbr Type
—————- —- — ——— ——– ————————-
Fa0/1            Altn BLK 19        128.1    P2p
Fa0/2            Root FWD 19        128.2    P2p
Fa0/3            Desg FWD 19        128.3    P2p

Switch>ena
Switch#config t
Switch(config)#hostname S2
S2(config)#interface range fa0/1-24
S2(config-if-range)#shutdown
S2(config-if-range)#interface range fa0/6, fa0/11, fa0/18
S2(config-if-range)#switchport mode access
S2(config-if-range)#no shutdown
S2(config-if-range)#interface range fa0/1, fa0/2
S2(config-if-range)#switchport mode trunk
S2(config-if-range)#no shutdown
S2(config-if-range)#interface vlan 1
S2(config-if)#ip address 172.17.10.2 255.255.255.0
S2(config-if)#no shutdown
S2(config-if)#exit
S2#sh spanning-tree 

VLAN0001
  Spanning tree enabled protocol ieee
  Root ID    Priority    32769
             Address     0001.438D.229D
             Cost        19
             Port        2(FastEthernet0/2)
             Hello Time  2 sec  Max Age 20 sec  Forward Delay 15 sec
  Bridge ID  Priority    32769  (priority 32768 sys-id-ext 1)
             Address     0090.217C.EB7C
             Hello Time  2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time  20
Interface        Role Sts Cost      Prio.Nbr Type
—————- —- — ——— ——– ————————-
Fa0/1            Desg FWD 19        128.1    P2p
Fa0/2            Root FWD 19        128.2    P2p
Fa0/6            Desg FWD 19        128.6    P2p
Fa0/11          Desg FWD 19        128.11  P2p
Fa0/18          Desg FWD 19        128.18  P2p

Switch>ena
Switch#config t
Switch(config)#hostname S3
S3(config)#interface range fa0/1-24
S3(config-if-range)#shutdown
S3(config-if-range)#interface range fa0/1, fa0/2
S3(config-if-range)#switchport mode trunk
S3(config-if-range)#no shutdown
S3(config-if-range)#interface vlan 1
S3(config-if)#ip address 172.17.10.3 255.255.255.0
S3(config-if)#no shutdown
S3(config-if)#exit
S3#sh spanning-tree 

VLAN0001
  Spanning tree enabled protocol ieee
  Root ID    Priority    32769
             Address     0001.438D.229D
             This bridge is the root
             Hello Time  2 sec  Max Age 20 sec  Forward Delay 15 sec
  Bridge ID  Priority    32769  (priority 32768 sys-id-ext 1)
             Address     0001.438D.229D
             Hello Time  2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time  20
Interface        Role Sts Cost      Prio.Nbr Type
—————- —- — ——— ——– ————————-
Fa0/1            Desg FWD 19        128.1    P2p
Fa0/2            Desg FWD 19        128.2    P2p



Download Cisco Packet Tracer 6.22
Download Cisco Packet Tracer 8.1.1

MCQ-SET 1

Dear Students, This Purpose of Preparation of Computer Network Online Test is in 30 Questions English. There is a collection of questions asked in the CCNA Exam. On answering each question one point will be given. And it is mandatory to bring 50% marks to pass. To start the test you have to click on Start Button. All the questions will have to be answered. Go to Last and click on Finish Button, after which your Result will appear on the screen. After clicking Finish, there will be three option shows below 1.Restart Quiz 2.View Question 3.Show Leader-board. After filling your name and e-mail id by clicking on the show leader-board, click on send, after which your result will be shown.

 

MCQ-SET 2

1. X.25 is an example of __________ network.




Answer is D)
packet switched


2. What is the maximum length of STP?




Answer is A)
200m


3. ISDN is an example of _______ network.




Answer is C)
circuit switched

4. What is the maximum data capacity of STP?




Answer is C)
100 mbps

5. In ______ topology if the computer cable is broken, networks get down




Answer is D)
bus

6. Terminators are used in ________ topology.




Answer is B)
bus

7. ________ layer decides which physical path the data should take.




Answer is B)
Physical

8. Print server uses spool which is a ______ that holds data before it is send to the printer.




Answer is C)
buffer

9. The ______ portion of LAN management software restricts access, records user activities and audit data etc.




Answer is B)
Performance management.

10. FDDI is a ____ network.




Answer is D)
ring

11. A distributed network configuration in which all data/information pass through a central computer is _____ network.




Answer is C)
star

12. The most flexibility in how devices are wired together is provided by ______




Answer is D)
ring

13. A central computer surrounded by one or more satellite computers is _______




Answer is C)
star

14. The internet is divided into over 200 top level __________




Answer is D)
domain

15. Every domain can have a set of ______ records associated with it.




Answer is B)
resource

16. GIF stands for _______




Answer is C)
Graphical Interchange Format

17. The error introduced by the finite number of bits per sample is called the _______ noise.




Answer is B)
quantization

18. ________ bursting allows a sender tot transmit a concatenated sequence of multiple frames in a single transmission.




Answer is D)
Frame

19. Protocols in which the sender sends one frame and then waits for an acknowledgement before proceeding are called __________




Answer is C)
stop and wait.

20. The data link layer takes the packet it gets from the network layer and encapsulates them into ___________




Answer is C)
frames

21. The data link layer takes the packets from _____ and encapsulates them into frames for transmission.




Answer is D)
network layer

22. Which one of the following task is not done by data link layer?




Answer is A)
channel coding

23. Protocols in which the sender waits for a positive acknowledgement before advancing to the next data item are often called ___________




Answer is D)
ARQ

24. The commonly used protocol for webpage transfer is ________




Answer is C)
HTTP

25. The frames which are intimated for receiving are called ________




Answer is C)
receiving window

26. The analysis which helps in checking whether the protocol is correct is _________




Answer is D)
reachability

27. The IP address of a system can be known using the DOS command _______




Answer is C)
ipconfig

28. Datagrams using header extension are called __________




Answer is A)
jumbograms

29. The application layer of a network ________




Answer is C)
consists of software being run on the computer connected to the network

30. Devices on one network can communicate with devices on another network via __________




Answer is A)
gateway.

How to Configure Default Route on Cisco Router
Download Cisco Packet Tracer 7.3.0
About me